<!DOCTYPE html>
<html lang="zh-hant" dir="ltr">
<head>
  <meta charset="utf-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <meta property="fb:app_id" content="161989317205664"/>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="x-dns-prefetch-control" content="on" />
<link rel="dns-prefetch" href="//s4.itho.me" />
<!--[if IE 9]>
<link rel="prefetch" href="//s4.itho.me" />
<![endif]-->
<link rel="shortcut icon" href="https://www.ithome.com.tw/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="久候多時，Java SE 9終於問世，語言的部分變化不大，但本身架構經過重新調整而變得更模組化" />
<meta property="og:description" content="久候多時，Java SE 9終於問世，語言的部分變化不大，但本身架構經過重新調整而變得更模組化" />
<meta name="description" content="久候多時，Java SE 9終於問世，語言的部分變化不大，但本身架構經過重新調整而變得更模組化" />
<meta name="abstract" content="久候多時，Java SE 9終於問世，語言的部分變化不大，但本身架構經過重新調整而變得更模組化" />
<link rel="canonical" href="https://www.ithome.com.tw/voice/118003" />
<meta property="og:site_name" content="iThome" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.ithome.com.tw/voice/118003" />
<meta property="og:title" content="Hello, JDK9？" />
<meta property="og:description" content="久候多時，Java SE 9終於問世，語言的部分變化不大，但本身架構經過重新調整而變得更模組化" />
<meta property="og:image" content="https://s4.itho.me/sites/default/files/avatar/picture-28-1403851920.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@ithomeonline" />
<meta name="twitter:creator:id" content="ithomeonline" />
<meta name="twitter:title" content="Hello, JDK9？" />
<meta name="twitter:description" content="久候多時，Java SE 9終於問世，語言的部分變化不大，但本身架構經過重新調整而變得更模組化" />
  <title>Hello, JDK9？ | iThome</title>
  <link type="text/css" rel="stylesheet" href="https://www.ithome.com.tw/sites/default/files/cdn/css/https/css_flilQulsp_Q6W1nu8SbQQvqQyTGiJZnEEP9IfGuEJng.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.ithome.com.tw/sites/default/files/cdn/css/https/css_DyKGQQ1ZooWJGZ-VHtjSC6JOIbxxbEHPZMULRR2aAqY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.ithome.com.tw/sites/default/files/cdn/css/https/css_lTVHntt3hPk7ZQJdCCO6A4w7Xouj-MEUFsY1WIBTl04.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.ithome.com.tw/sites/default/files/cdn/css/https/css_5-C20M4LMFmvQXDBt5_4NUX-dFPEodBeDSkzHdfuHCY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.ithome.com.tw/sites/default/files/cdn/css/https/css_aYIN3mq1DmLT6Di-4-Gd2Se05n7P-awcXq0wcXZEGrI.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.ithome.com.tw/sites/all/themes/ithomeStyle/css/font-awesome/css/font-awesome.min.css" media="all" />
  <!-- HTML5 element support for IE6-8 -->
  <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->
  <script src="https://cdn.optimizely.com/js/5545970059.js"></script>
  <script src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.7/jquery.min.js'>\x3C/script>")</script>
<script src="https://www.ithome.com.tw/sites/default/files/js/js_V1ZuwJK9uzfm6fFffOcHHubfxnimoxnbgG58pvTQdpY.js"></script>
<script src="https://www.ithome.com.tw/sites/default/files/js/js_V6wBDmA8AiXYV7yNdxSYWbjyBTZz58as_PtacAj7MoA.js"></script>
<script src="https://www.ithome.com.tw/sites/default/files/js/js_PpWj1_0vz25Pp3KJwGcWwKOJWJfOoPE7svepJH4xqZA.js"></script>
<script src="https://www.ithome.com.tw/sites/default/files/js/js_q15x_O-9imkRmTs1RyvjELo4uxbnh8J6CSO5egfMvq4.js"></script>
<script>jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"ithomeStyle","theme_token":"lxj7nMkroVFMfl44_x0VQy7mPrEL5FPeNlsn6vqtSF4","js":{"modules\/statistics\/statistics.js":1,"\/\/ajax.googleapis.com\/ajax\/libs\/jquery\/1.7.2\/jquery.min.js":1,"0":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/libraries\/prettify\/prettify.js":1,"sites\/all\/libraries\/prettify\/lang-css.js":1,"sites\/all\/libraries\/prettify\/lang-sql.js":1,"sites\/all\/libraries\/prettify\/lang-wiki.js":1,"sites\/all\/libraries\/prettify\/lang-yaml.js":1,"public:\/\/languages\/zh-hant_EynS4tarGHEmr5eaBV3EzbgWhvNJW-hDCo2uqR3SWPQ.js":1,"sites\/all\/modules\/colorbox\/js\/colorbox.js":1,"sites\/all\/modules\/colorbox\/styles\/default\/colorbox_style.js":1,"sites\/all\/modules\/prettify\/prettify.loader.js":1,"sites\/all\/themes\/ithomeStyle\/js\/jquery.featureList.js":1,"sites\/all\/themes\/ithomeStyle\/js\/main.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-affix.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-alert.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-button.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-carousel.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-collapse.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-dropdown.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-modal.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-tooltip.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-popover.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-scrollspy.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-transition.js":1,"sites\/all\/themes\/ithomeStyle\/bootstrap\/js\/bootstrap-typeahead.js":1},"css":{"modules\/system\/system.base.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"sites\/all\/modules\/date\/date_repeat_field\/date_repeat_field.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/youtube\/css\/youtube.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/ckeditor.css":1,"sites\/all\/modules\/colorbox\/styles\/default\/colorbox_style.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/panels\/css\/panels.css":1,"sites\/all\/themes\/ithomeStyle\/css\/style.css":1,"sites\/all\/modules\/prettify\/styles\/naspinski.css":1}},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"jcarousel":{"ajaxPath":"\/jcarousel\/ajax\/views"},"prettify":{"linenums":true,"match":".content","nocode":"no-code","custom":[],"markup":{"code":true,"pre":true,"precode":false}},"statistics":{"data":{"nid":"118003"},"url":"\/modules\/statistics\/statistics.php"}});</script>
</head>
<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-118003 node-type-voice" >
  <div id="fb-root"></div>
  <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/zh_TW/all.js#xfbml=1&appId=161989317205664";
      fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));
  </script>
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">移至主內容</a>
  </div>
    <header id="navbar" role="banner" class="navbar navbar-fixed-top">
  <div class="navbar-inner">
    <div class="container-fluid">
      <!-- .btn-navbar is used as the toggle for collapsed navbar content -->
      <a class="btn btn-navbar" data-toggle="collapse" data-target=".nav-collapse">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </a>

              <a class="logo pull-left" href="/" title="首頁">
          <img src="https://s4.itho.me/sites/default/files/ithome_logo_0.png" alt="首頁" />
        </a>
      
      
              <div class="nav-collapse collapse">
          <nav role="navigation">
                          <ul class="menu nav"><li class="first leaf"><a href="/news">新聞</a></li>
<li class="leaf"><a href="/buying">產品評測</a></li>
<li class="leaf"><a href="/tech">技術</a></li>
<li class="leaf"><a href="/feature">專題</a></li>
<li class="leaf"><a href="/big-data">Big Data</a></li>
<li class="leaf"><a href="/cloud">Cloud</a></li>
<li class="leaf"><a href="/devops">DevOps</a></li>
<li class="leaf"><a href="/security">資安</a></li>
<li class="leaf"><a href="/video">Video</a></li>
<li class="expanded dropdown"><a href="/seminar" class="dropdown-toggle" data-toggle="dropdown" data-target="#">研討會 <span class="caret"></span></a><ul class="dropdown-menu"><li class="first leaf"><a href="/seminar">研討會訊息</a></li>
<li class="last leaf"><a href="/cfp">議程／講師徵求</a></li>
</ul></li>
<li class="last expanded dropdown"><a class="hidden-phone dropdown-toggle nolink" data-toggle="dropdown" data-target="#">社群 <span class="caret"></span></a><ul class="dropdown-menu"><li class="first leaf"><a href="http://ithelp.ithome.com.tw" title="IT人的知識交流平臺">iT邦幫忙</a></li>
<li class="leaf"><a href="http://download.ithome.com.tw">iThome download</a></li>
<li class="leaf"><a href="https://www.itinnovators.com.tw">IT Innovators Club</a></li>
<li class="leaf"><a href="https://learning.ithome.com.tw/">iThome Learning</a></li>
<li class="leaf"><a href="https://workshop.ithome.com.tw/">iThome Workshop</a></li>
<li class="last leaf"><a href="https://techtalk.ithome.com.tw/">TechTalk</a></li>
</ul></li>
</ul>                                      <ul class="menu nav pull-right"><li class="first last leaf"><a href="/search" class="icon-search">搜尋</a></li>
</ul>                                  </nav>
        </div>
          </div>
  </div>
</header>

<header id="headerbar" role="banner" class="hidden-phone">
  <div class="headerbar-wrap">
        <div class="region region-before-header">
    <section id="block-block-3" class="block block-block hidden-phone clearfix">

      
  <style>
#div_cube3d_pic { width: 100% !important}
#div_cube3d_exp {left:0 !important; position: relative !important; margin: 0 auto}
#headerbar .container-fluid {max-width: 1350px !important}
</style>
<div style="max-width:1350px; margin: 0 auto;padding: 0 0 10px">
    <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=90&channel=ithome_h&encoding=Utf8"> </script>
</div>
<!-- ad0310  -->
<div id="ad-on-top">
  <div class="ad-720">  
  
     <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=3&channel=ithome_h&encoding=Utf8"> </script>  

  </div>
   <div class="ad-200 inline" style="margin-left: 15px"> 
  <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=4&channel=ithome_h&encoding=Utf8"> </script>
</div>
    <div class="ad-text-top">
     <div class="text-item">
      <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=0&channel=ithome_h&encoding=Utf8"> </script>
     </div>
     <div class="text-item">
        <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=23&channel=ithome_h&encoding=Utf8"> </script>
     </div>
     <div class="text-item">
         <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=1&channel=ithome_h&encoding=Utf8"> </script>
     </div>
   </div>
   <br style="clear:both"> 
</div></section> <!-- /.block -->
  </div>
    </div>
</header>


<div class="main-container container-fluid">

  
  <header role="banner" id="page-header">
    
      <div class="region region-header">
    <section id="block-views-view-news-article-category" class="block block-views clearfix">

      
  <div class="view view-view-news view-id-view_news view-display-id-article_category view-dom-id-211ac46ed29f22315660e0a01526aeb9">
        
  
  
      <div class="view-content">
        <div class="category-label">
      
              
              
              
              
              
              
              
          <a href="/tags/%E7%A8%8B%E5%BC%8F%E4%BA%BA%EF%BD%9C%E6%9E%97%E4%BF%A1%E8%89%AF">程式人｜林信良</a>    
              </div>
    </div>
  
  
  
  
  
  
</div></section> <!-- /.block -->
  </div>

                  <h1 class="page-header">Hello, JDK9？</h1>
        <div class="content-summary"> <p>久候多時，Java SE 9終於問世，語言的部分變化不大，但本身架構經過重新調整而變得更模組化</p>
  </div>
            </header> <!-- /#header -->

  <div class="row-fluid">
      
    
      
    <section class="main-content span9">  
                                                                      <section id="block-block-22" class="block block-block socail-btns-on-top clearfix">

      
  <style>
#block-block-22 { width: 520px}
.social-btn-set {float:right; margin: 10px 0}
.social-btn-set .fan-page {margin: 0 15px 0 0; display: inline-block}
.social-btn-set .gplus {margin: 0 0 0 15px ; display: inline-block}
.fb-like.fb_iframe_widget {display: inline-block}
@media screen and (max-width: 480px) {
  #block-block-22 {width: 100%}
  .social-btn-set {float: left}
  .social-btn-set .fan-page,   .social-btn-set .fb-like,   .social-btn-set .gplus  { width: 100% !important; height: 40px; display: block; margin-left: 15px  }
  .social-btn-set .fb-like { margin-left: 15px }
  .social-btn-set .fan-page .fb-like {width: 105px !important; float: left; margin-left: 0}
  .social-btn-set .gplus {padding-top: 20px}
}
/* firefox fix */
.gplus div { vertical-align: top !important}
</style>
<div class="social-btn-set">
  <div class="fan-page wrap">
     <div class="fb-like" data-href="https://www.facebook.com/ithomeonline" data-width="300" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"> </div>  
     <div style="display: inline-block">按讚加入iThome粉絲團</div>
  </div>
  <div class="fb-like" data-layout="button_count" data-action="like" data-show-faces="false" data-share="true" style="display: inline-block"></div>
  <div class="gplus">
  <!-- Place this tag where you want the +1 button to render. -->
  <div class="g-plusone" data-size="medium"></div>
  <!-- Place this tag after the last +1 button tag. -->
  <script type="text/javascript">
    window.___gcfg = {lang: 'zh-TW'};
    (function() {
      var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
      po.src = 'https://apis.google.com/js/platform.js';
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
    })();
  </script>
</div>
</div>
<br class="clear:both"></section> <!-- /.block -->
<section id="block-views-view-news-custom-submitted" class="block block-views clearfix">

      
  <div class="view view-view-news view-id-view_news view-display-id-custom_submitted view-dom-id-b8d23d52e00b398cde730b2771be4cd3">
        
  
  
      <div class="view-content">
        <div>
      
  <span class="views-field views-field-created">        <span class="field-content"><div class="submitted">
  <span>文/<span class="author"><a href="/users/%E6%9E%97%E4%BF%A1%E8%89%AF">林信良</a></span>
  <span class="seprate">|</span>
  <span class="created">2017-11-18</span><span class="pub-wording">發表</span>
</div></span>  </span>  </div>
    </div>
  
  
  
  
  
  
</div></section> <!-- /.block -->

<article id="node-118003" class="node node-voice node-promoted  clearfix">
  <header>
                    
      </header>
    <div class="row-fluid">
    <div class="contents-wrap">
    <div class="content">
     
    <div class="side-extra">
      <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=9&amp;channel=ithome_h&amp;encoding=Utf8"></script>
  </div>

<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"> <p>歷經一波三折，Java SE 9終於在9月21日正式釋出了，從語言層面來看，Java SE 9似乎沒什麼太大變化，不過，你知道下個版本的Java SE版本號可能會是18.3嗎？還有，為什麼更新完JDK之後，IDE就整個無法開啟了？</p>
<p>別忘了，Java SE 9的重大特性之一是模組化，JDK/JRE也因應而做了重新架構。</p>
<p><span style="font-size:24px;"><strong>下個版本是Java 18.3？</strong></span></p>
<p>在Java走過二十多個年頭的這段期間，JDK曾經有過一些重大的版本號變化，第一個重大版本變更是J2SE 1.2，這個版本就是老一輩Java人最熟悉的Java 2，過去臺灣昇陽舉辦的Java Two研討會也是以此為名，一些開發者口中始終改不了口的J2EE，也是基於此版本，可見此版本之重要性；版本號大躍進，第一次則是發生在J2SE 1.4直跳J2SE 5.0，這是為了彰顯這個版本與之前版本有極大不同，像是語法上的簡化、增加泛型、列舉、標註等重大功能。</p>
<p>然而，J2SE 5.0這版本號又是2又是5的，令人困惑，因而2006年底發表的Java SE決定不再帶有2這個名稱，簡稱Java SE 6，之後版本就基於重大特性，分別又發表了Java SE 7到Java SE 9。</p>
<p>平均來說，在Java SE 6之前，約二年左右會發布Java重大版本，中間則會有一些為了修正臭蟲、安全性而發布的小更新版本。然而，從Java SE 6之後，由於營收、併購或技術、安全性修正等因素，使得發布時程變得沒有規律，經常就是一延再延，重大特性也就被一推再推地放至下個版本，像是Java SE 7的Lambda與Jigsaw，一開始被推至Java SE 8，後來Jigsaw又再度被推延至Java SE 9。</p>
<p>然而，除了重大特性之外，還有許多對開發者有用的小特性，也因此被迫隨著重大版本才能釋出，為此，Oracle的Java架構長Mark Reinhold，在2012年就曾因Jigsaw無法實現於Java SE 8時希望，未來Java的發布可以是基於時間而非基於重大特性，以半年為週期，持續發布新版本，讓一些有用的小特性（例如jshell這種），也能在這些新版本被開發者使用。</p>
<p>因此，從Java SE 9之後有了新的版本號時間軸，Oracle在〈Oracle Java SE Support Roadmap〉（<a href="https://goo.gl/7Civd5">https://goo.gl/7Civd5</a>）指出，未來新的版本號會是基於$YEAR.$MONTH格式，例如，下個版本預計會是2018年3月釋出，因此版本會是Java SE 18.3，以後若發現不是Java SE 9字樣，而是Java SE 18.3這類的字樣，就不要太訝異了。</p>
<p>這樣的版本號模式，對Java來說，有些新鮮，然而，有些語言就是採持續而頻繁地釋出新版本，像是Go語言，而基於時間、非基於重大特性來釋出的軟體，最典型的範例就是Ubuntu。</p>
<p>未來，Java SE 18.3等版本將會是短期支援版本，〈Oracle Java SE Support Roadmap〉指出，在下個小版本釋出後，上個版本就不再維護，使用者要趕快更新版本，Oracle也有Java SE的長期支援版本，三年為週期，可透過Oracle Java SE Advanced、Oracle Java SE Advanced Desktop，或是Java SE Suite取得，另外，Java SE 8會是長期支援版本，將支援至2022年。</p>
<p><span style="font-size:24px;"><strong>JDK/JRE重新架構了！</strong></span></p>
<p>跟過去安裝完JDK不同，在更新為JDK9之後，有可能發生的最差情況是，IDE等相關開發工具完全無法啟動了，這是因為Java SE 9重新架構了JDK與JRE的實體結構，如果開發工具會試圖尋找rt.jar、tools.jar之類的檔案，很抱歉，JDK9/JRE9中沒有這些檔案（或其他相關目錄），你得升級開發工具至可以支援JDK9/JRE9的版本。</p>
<p>Java SE 9支援模組化，而JDK/JRE本身也為了模組化而重新架構，首先，JDK本身的私用JRE（Private JRE）沒有專屬目錄——Java SE API實作原始碼的部份，改放到lib中的src.zip，而其中細分為java.base等各個模組，若要找到想察看的原始碼，得先知道它們被歸到了哪個模組，之後才是查看對應的套件。</p>
<p>rt.jar、tools.jar之類的檔案，由什麼取代了呢？在JDK中有個jmods目錄，裏頭有一堆.jmod檔案，主檔名為模組名稱，目前它是使用zip格式（未來可能會變更），使用解壓縮軟體開啟對應的模組，就可以察看其中的.class檔案，JMOD檔案對應JAR檔案在編譯時期的角色。</p>
<p>Java SE 9模組平臺系統為了改進效能、安全與維護性，在執行時期會使用模組執行時期映像檔（Modular Run-Time Images），又稱JIMAGE，無論是JDK或公用JRE（Public JRE）的目錄，都會有lib目錄，其中有個modules檔案，若使用javac編譯時加上-version，就會看到執行編譯的過程中，從modules載入了module-info.class及相關類別，modules檔案包含的是.class檔案的執行時期格式，也就是，相當於JAR的.class在執行時期載入JVM之後的角色。</p>
<p><span style="font-size:24px;"><strong>JAR/JMOD/JIMAGE？</strong></span></p>
<p>身為Java開發者，對於JAR（Java Archive）檔案應是相當熟悉，JAR檔案可用來封裝.java原始碼，或者是編譯好的.class，可以用在編譯或執行時期。</p>
<p>在JDK9中，JAR依舊可以使用，更進一步地用來封裝模組，另外，也支援多版本JAR（Multi-release JAR），可以在JAR檔案中，封裝針對不同JDK的.class檔案，讓新版JDK使用新的.class，而舊版JDK使用舊格式.class，詳情可參考〈JEP 238: Multi-Release JAR Files〉（<a href="https://goo.gl/HgcrPG">https://goo.gl/HgcrPG</a>）。</p>
<p>JDK9也引進了新的JMOD格式來封裝模組，目的在於可以處理比JAR更多的檔案類型，像是原生指令、組態檔等，有些文件將JMOD描述為擴充版本的JAR，可以使用JDK9附的jmod工具程式來建立、查看或取出JMOD檔案的內容，在編譯或鏈結（link）時，也就是使用javac或jlink工具程式時，可以指定--module-path引數至.jmod檔案所在路徑，然而執行時期不支援JMOD檔案。你可以查看〈jmod〉（<a href="https://goo.gl/pZyQKr">https://goo.gl/pZyQKr</a>）瞭解如何使用jmod工具程式。</p>
<p>在執行時期，JDK9使用的是執行時期映像檔，可以使用JDK9附的jlink工具程式，建立一個專用的執行時期映像檔，其中只包含你指定的模組，使用jlink時的模組來源，可以是模組化的JAR，或者是JMOD，建立後的目錄中，會有java等工具程式。</p>
<p>如果執行時期映像檔中，包含了進入點模組（建立.jmod時可使用--main-class指定），只要執行jlink建立的目錄中之java，並使用-m指定進入點模組名稱即可。而且，執行時期映像檔只用於執行時期，無法用於編譯。你可以查看〈jlink〉（<a href="https://goo.gl/bcT8Lx">https://goo.gl/bcT8Lx</a>）瞭解如何使用jlink工具程式。</p>
<p>因而JDK9之後，有三種方式可以發布你的程式庫或應用程式。如果只是希望客戶端使用應用程式，發布jlink建立的東西就可以了；如果希望客戶端可以自訂執行時期映像檔，那麼可以發布JMOD；如果是給開發者使用的程式庫，建議採用支援模組化的JAR檔案。</p>
<p>而正如我先前專欄〈Java 9模組化概觀〉中談到的，未來的Java開發生態中，類別路徑應會逐漸淡出，新開發的專案建議採用模組化，並改用模組路徑指定程式庫來源。</p>
<p><span style="font-size:24px;"><strong>不是裝好就沒事了</strong></span></p>
<p>以往在更新JDK後，相關的開發工具，基本上應該都可以運行而不會有太大問題，然而在更新JDK9之後，若你的開發工具連開都開不起來，別急著對JDK9開罵，先瞭解一下JDK9本身做了哪些改變，然後看看這些工具有沒有更新至支援JDK9的版本。</p>
<p>畢竟JDK9的重大特性就是模組化，也就因此JDK/JRE本身也做了重新架構（正所謂吃自己的狗糧），對於JDK9來說，不能存著裝好就沒事的態度，藉由瞭解JDK9本身如何重新架構，進一步地就會瞭解到JAR的變化，以及JMOD與JIMAGE的存在與目的，對於未來開發程式時如何因應模組化以及如何發布，也就能夠有更深的認識。</p>
 </div></div></div>    <div>
  </div>
  </div>
       
  </article> 
<section id="block-views-view-news-expert-profile" class="block block-views clearfix">

        <h2 class="block-title">作者簡介</h2>
    
  <div class="view view-view-news view-id-view_news view-display-id-expert_profile column-author-profile view-dom-id-61b1fdbf9e23146862b6e5cf58b05aad">
        
  
  
      <div class="view-content">
        <div class="author-profile">
      
  <div class="views-field views-field-field-user-profile">        <div class="field-content"><div class="expert-profile">
  <div class="avatar">  <div class="user-picture">
    <img src="https://s4.itho.me/sites/default/files/styles/medium/public/avatar/picture-28-1403851920.png?itok=CIB67fvX" alt="caterpillar&#039;s 的頭像" title="caterpillar&#039;s 的頭像" />  </div>
 </div>  
  <div class="author"><a href="/users/林信良">林信良</a></div>  
  <div class="profile"><p>因在網路上經營「良葛格學習筆記」（openhome.cc）而聞名，曾任昇陽教育訓練中心技術顧問、甲骨文教育訓練中心授權講師，目前為自由工作者，專長為技術寫作、翻譯與教育訓練。喜好研究程式語言、框架、社群，從中學習設計、典範及文化。閒暇之餘記錄所學，技術文件涵蓋C/C++、Java、Ruby/Rails、Python、JavaScript、Haskell等多個領域。</p>
 </div>  
</div></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div></section> <!-- /.block -->
<section id="block-block-45" class="block block-block clearfix">

      
  <div style="margin-left:20%;text-align: center">
<div style="max-width: 500px; background: url(https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/fb_fanpagelike_bg.gif) 0 0 repeat-x;position: relative; margin: 0 auto -30px"> 
     <p id="like-ithome-fb-pages-btn" style="margin: 15px auto; width: 300px; text-align:center; "><a href="https://www.facebook.com/ithomeonline" target="_blank"><img alt="" src="https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/fb_300x114_s3.gif" style="width: 300px; height: 114px;" /></a></p>
     <div class="fan-page wrap" style="position: relative; bottom: 40px; width: 300px; margin: 0 auto">
       <div class="fb-like" data-href="https://www.facebook.com/ithomeonline" data-width="300" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"></div> 
     </div>
<div>
</div>
</section> <!-- /.block -->
<section id="block-block-23" class="block block-block socail-btns-on-bottom clearfix">

      
  <style>
#block-block-22 { width: 520px}
.social-btn-set {float:right; margin: 10px 0}
.social-btn-set .fan-page {margin: 0 15px 0 0; display: inline-block}
.social-btn-set .gplus {margin: 0 0 0 15px ; display: inline-block}
@media screen and (max-width: 480px) {
  #block-block-22 {width: 100%}
  .social-btn-set {float: left}
  .social-btn-set .fan-page,   .social-btn-set .fb-like,   .social-btn-set .gplus  { width: 100% !important; height: 40px; display: block; margin-left: 15px  }
  .social-btn-set .fb-like { margin-left: 15px }
  .social-btn-set .fan-page .fb-like {width: 105px !important; float: left; margin-left: 0}
  .social-btn-set .gplus {padding-top: 20px}
}
.addthis_default_style .at300b  {float: right}
/* firefox fix */
.gplus div { vertical-align: top !important}
</style>
<div class="social-btn-set">
  <div class="fb-like" data-layout="button_count" data-action="like" data-show-faces="false" data-share="true"></div>
  <div class="gplus">
  <!-- Place this tag where you want the +1 button to render. -->
  <div class="g-plusone" data-size="medium"></div>
  <!-- Place this tag after the last +1 button tag. -->
  <script type="text/javascript">
    window.___gcfg = {lang: 'zh-TW'};
    (function() {
      var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
      po.src = 'https://apis.google.com/js/platform.js';
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
    })();
  </script>
</div>
</div>
<br class="clear:both">
<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style addthis_32x32_style" style="clear:both; padding-top: 15px; margin-right: 20px">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_google_plusone_share"></a>
<a class="addthis_button_linkedin"></a>
<!-- <a class="addthis_button_plurk"></a> -->
<a class="addthis_button_twitter"></a>
</div>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true, "data_track_addressbar": false};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52dbf6795940ab30"></script>
<!-- AddThis Button END --></section> <!-- /.block -->
<section id="block-block-37" class="block block-block clearfix">

      
  <div style="text-align: right; margin: 25px 0 -15px">
  <div class="fb-comments" data-href="https://www.ithome.com.tw/voice/118003" data-numposts="5" data-colorscheme="light" width="620"></div>
</div> 
</section> <!-- /.block -->
<section id="block-block-10" class="block block-block clearfix">

      
  <div class="span8 offset4">
<div class="ad-text-in-middle">
  <div class="wrap">
<div class="text">
     <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=2&channel=ithome_h&encoding=Utf8"> </script>
</div>
  <div class="ad-annoncement"> Advertisement</div>
  </div>
</div>
</div></section> <!-- /.block -->
<section id="block-views-similarterms-block" class="block block-views clearfix">

        <h2 class="block-title">更多 iThome相關內容</h2>
    
  <div class="view view-similarterms view-id-similarterms view-display-id-block view-dom-id-94d705f1f8ea5cbd9b0e21e6e69133ba">
        
  
  
      <div class="view-content">
      <div class="item-list">    <ul>          <li class="views-row-odd views-row-first">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/voice/107333">你的程式有多快？</a></span>  </div></li>
          <li class="views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/voice/104623">不重複的深度學習</a></span>  </div></li>
          <li class="views-row-odd">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/voice/104417">思考Python的型態提示</a></span>  </div></li>
          <li class="views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/voice/104207">Python 2.x或3.x？</a></span>  </div></li>
          <li class="views-row-odd">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/voice/103992">如何閱讀英文技術文件</a></span>  </div></li>
          <li class="views-row-even views-row-last">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/voice/103634">另一種程式設計選擇</a></span>  </div></li>
      </ul></div>    </div>
  
  
  
  
  
  
</div></section> <!-- /.block -->
    </section>

          <aside class="span3 aside-right" role="complementary">
          <div class="region region-sidebar-second">
    <section id="block-block-4" class="block block-block clearfix">

      
  <div class="side-extra">
   <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=47&channel=ithome_h&encoding=Utf8"> </script>
</div>
</section> <!-- /.block -->
<section id="block-block-43" class="block block-block clearfix">

      
  <div style="position: relative">
<p id="like-ithome-fb-pages-btn" style="margin: 15px auto; width: 300px; text-align:center; "><a href="https://www.facebook.com/ithomeonline" target="_blank"><img alt="" src="https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/fb_300x114_s3.gif" style="width: 300px; height: 114px;" /></a></p>
 <div class="fan-page wrap" style="position: absolute; left: 110px; bottom: 6px">
     <div class="fb-like" data-href="https://www.facebook.com/ithomeonline" data-width="300" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"></div> 
  </div>
</div>

</section> <!-- /.block -->
<section id="block-views-hot-news-aside-popular" class="block block-views clearfix">

        <h2 class="block-title">熱門新聞</h2>
    
  <div class="view view-hot-news view-id-hot_news view-display-id-aside_popular view-dom-id-98ed4002fe1d777d6e875ed412b0aa07">
        
  
  
      <div class="view-content">
        <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118304"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/doseuhyxkaaija_.jpg_large.jpg?itok=4WOnDyQN" width="180" height="180" alt="" title="美國洛斯阿拉莫斯國家實驗室最近展示了，他們利用750片樹莓派成功打造一臺超級電腦的最新成果，未來還要挑戰最多1萬個節點的擴充，運算效能甚至完全不輸給當今Peta級的超級電腦，這臺樹莓派超級電腦，本周也在美國丹佛舉行的2017超級電腦展上公開展出 。" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118304">美實驗室用750個樹莓派打造運算叢集，更要挑戰成為全球前百大Peta級超級電腦</a>
      </div>
      <p class="created">2017-11-17</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118260"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/firefox-1.jpg?itok=sq4yLZPY" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118260">Firefox Quantum瀏覽器正式版11月14日全球同步推出</a>
      </div>
      <p class="created">2017-11-14</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118196"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/fbi-hacker-1_1.jpg?itok=ehH_jmKW" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118196">全球遭盜帳號多達33億個，Google新研究找出帳號被盜3大主因</a>
      </div>
      <p class="created">2017-11-13</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118273"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/petahpc1.jpg?itok=oNyFqPOh" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118273">台灣重返全球百大超級電腦，國網中心新系統明年4月上線</a>
      </div>
      <p class="created">2017-11-15</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118213"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/avgater_tu_pian_lai_yuan_bogner.sh_.png?itok=JLVjRVNi" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118213">十多款防毒軟體隔離恐失效，AVGater漏洞能縱放被封鎖的惡意程式</a>
      </div>
      <p class="created">2017-11-13</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118302"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/taiwanpay-1.jpg?itok=qf95JhzQ" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118302">「台灣Pay」支付品牌正式亮相，結合金融卡要讓行動支付更普及</a>
      </div>
      <p class="created">2017-11-16</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118286"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/vs-code-ls-session.jpg?itok=5Gr9FsNX" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118286">好用！微軟發表Visual Studio Live Share，寫程式能像共享文件一樣多人同時編輯了</a>
      </div>
      <p class="created">2017-11-16</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118205"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/po_jie_iphone_x.jpg?itok=NVQUGZ7K" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118205">資安研究人員騙過iPhone X的Face ID驗證，材料費只花了150美元</a>
      </div>
      <p class="created">2017-11-13</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118203"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/mcafeeshou_ye_.jpg?itok=asBzUsQI" width="180" height="180" alt="" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118203">空白Word暗藏木馬，俄國駭客組織用微軟DDE協定攻擊散佈惡意程式</a>
      </div>
      <p class="created">2017-11-13</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
  <div class="item aside-list">
    <article class="aside_list_with_thumb">
  <div class="wrap">
      <div class="icon">
      <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news/118298"><img src="https://s4.itho.me/sites/default/files/styles/square_thumbnail/public/field/image/win7_0_0_1_0.jpg?itok=pwDLEivl" width="180" height="180" alt="" title="示意圖，與新聞事件無關。" /></a></div></div></div>    </div>
      <div class="content">
      <div class="title">
        <a href="/news/118298">微軟修補藏了17年的Office漏洞</a>
      </div>
      <p class="created">2017-11-16</p>
    </div> <!-- end of content -->
  </div> <!-- end of wrap -->
</article> 
  </div>
    </div>
  
  
  
  
  
  
</div></section> <!-- /.block -->
<section id="block-views-view-top-story-aside-list" class="block block-views clearfix">

        <h2 class="block-title">專題報導</h2>
    
  <div id="story-carousel" class="view view-view-top-story view-id-view_top_story view-display-id-aside_list feature-aside-list view-dom-id-8fea129907b7cd6b69c7fb32360a4437">
        
  
  
      <div class="view-content carousel-inner">
        <div class="aside-list-item active">
      
          <a href="/article/118000"><img src="https://s4.itho.me/sites/default/files/styles/picture_size_small/public/960x420-841-feng_mian_gu_shi_-javawa_kuang_-open-01.jpg?itok=rBXtPaL3" width="300" height="132" alt="" /></a>    
          <a href="/article/118000">挖礦綁架，小心你的瀏覽器變礦工</a>    </div>
  <div class="aside-list-item">
      
          <a href="/article/117881"><img src="https://s4.itho.me/sites/default/files/styles/picture_size_small/public/960x420-840-cai_gou_-1-open-960.jpg?itok=pNe6qj9Q" width="300" height="132" alt="" /></a>    
          <a href="/article/117881">2017全快閃儲存陣列採購大特輯【市場總覽篇】</a>    </div>
  <div class="aside-list-item">
      
          <a href="/article/117171"><img src="https://s4.itho.me/sites/default/files/styles/picture_size_small/public/960x420-836-cai_gou_-1-open.jpg?itok=2X5DEprO" width="300" height="132" alt="" /></a>    
          <a href="/article/117171">網頁安全閘道設備採購大特輯</a>    </div>
  <div class="aside-list-item">
      
          <a href="/article/117602"><img src="https://s4.itho.me/sites/default/files/styles/picture_size_small/public/960x420-839-feng_mian_gu_shi_-open-01.jpg?itok=FRx1B5Mh" width="300" height="132" alt="" /></a>    
          <a href="/article/117602">Wi-Fi加密大崩壞</a>    </div>
  <div class="aside-list-item">
      
          <a href="/article/117287"><img src="https://s4.itho.me/sites/default/files/styles/picture_size_small/public/815x315-837-feng_mian_gu_shi_-open-01-960.jpg?itok=7r3QeY3s" width="300" height="132" alt="" /></a>    
          <a href="/article/117287">資料驅動治理，讓數據說話</a>    </div>
    </div>
  
  
  
  
        <div class="more-link-deco"><a href="http://www.ithome.com.tw/feature" class="more-link-deco">更多專題報導</a></div>  
  
</div></section> <!-- /.block -->
  </div>
      </aside>  <!-- /#sidebar-second -->
    
  </div>
</div>

<footer class="footer">
      <div class="region region-footer">
    <section id="block-block-7" class="block block-block clearfix">

      
  <div id="ad-on-top">
  <div class="ad-720">  
   <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=41&channel=ithome_h&encoding=Utf8"> </script>

  </div>
    <div class="ad-200 inline" style="margin-left: 15px">
   <script type="text/javascript" src="https://adcl.pchome.com.tw:443/getAd2JS.html?type=4&channel=ithome_h&encoding=Utf8"> </script>
    </div>
</div></section> <!-- /.block -->
<section id="block-block-2" class="block block-block clearfix">

      
  <ul class="copyright inline"><li>電週文化事業版權所有、轉載必究  | Copyright &copy; iThome</li><li><a href="/aboutus/">刊登廣告</a></li><li><a href="https://service.ithome.com.tw/">訂閱週刊</a></li><li><a href="/aboutus/">授權服務</a></li><li><a href="/aboutus/">服務信箱</a></li><li><a href="/terms">隱私權聲明與會員使用條款</a></li><li><a href="/aboutus/">關於iThome</a></li><li><a href="/rss">RSS</a></li> <li><a href="/jobs">徵才</a> </li></ul>
<!--  2014.2.21 改版上線 --></section> <!-- /.block -->
<section id="block-block-24" class="block block-block clearfix">

      
  <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-3355931-5', 'auto');
  ga('send', 'pageview');
     
</script>
</section> <!-- /.block -->
<section id="block-block-72" class="block block-block clearfix">

      
  <style>
    #cyber {
        background-color: #ffffff;
        text-align: center
    }
</style>
<script>
    (function($) {
        // release date
        var start = Date.parse("2017-9-14");
        var end = Date.parse("2017-9-20");
        var today = new Date;
        var currentTime = today.getTime();
        var theDay = today.getDay();
        
        isInDuration = (currentTime > start && currentTime < end);
        //isInWeekday = (theDay == 1 || theDay == 3 || theDay == 5);
                    
        //if(isInDuration && isInWeekday){
        if(isInDuration){    
           //var setNum = (theDay == 2) ? 0:1;
        var setNum = 0;

        // multi image set
          var imgSet = []; 
         //var cdnPath = "https://d3jcp1umdd59vg.cloudfront.net";
          imgSet.push([
            'https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/egov1400x197-v2c1.jpg',
            'https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/egov1400x197-v2c2.jpg',
            'https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/egov1400x197-v2c3.jpg',
            'https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/egov1400x197-v2c4.jpg',
            'https://d3jcp1umdd59vg.cloudfront.net/sites/default/files/egov1400x197-v2c5.jpg'
          ]);
        
        // multi labes set
          var labels = ["eGov"];
          var theLabel = labels[setNum]; 

             
        // setting
        var img_link = imgSet[setNum];
        var Carousel_interval = 3 * 1000;

        // main
        var $document = $(document);
        var $navbar = $('#navbar');
        var $body = $('body');
        var $cyber;
        var $cyber_img;

        // function
        var fixed_layout = function() {
            var img_height = $cyber.height();
            var navbar_height = $navbar.height();
            var is_Top = ($document.scrollTop() > img_height);
            var css_val = (is_Top) ? navbar_height : '0';
            $navbar.toggleClass('navbar-fixed-top', is_Top);
            $body.css('cssText', 'padding-top: ' + css_val + ' !important');
        }

        var Run_carousel = function() {
            var index = $cyber_img.data('index') || 0;
            index = (index > img_link.length) ? 0 : index;
            $cyber_img.attr('src', img_link[index]).data('index', index + 1);
            setTimeout(Run_carousel, Carousel_interval);
        }

        // EVENT
        var EVENT_init = function() {
            var cyber_html = '<div id="cyber"><a href="https://egov.ithome.com.tw/?utm_source=ithome&utm_medium=navibanner&utm_campaign=egov0914" target="_blank"><img /></a></div>';
            $navbar.before(cyber_html).css('margin-bottom', '0');
            $cyber = $('#cyber');
            $cyber_img = $cyber.find('img');
            $cyber_link = $cyber.find('a');

            $cyber_link.click(function(){
                ga('send', {
                    hitType: 'event',
                    eventCategory: 'NavBanner',
                    eventAction: 'click',
                    eventLabel: theLabel
                });
            });

        }

        var scrollTimeout;
        var EVENT_scroll = function(event) {
            if (scrollTimeout) {
                clearTimeout(scrollTimeout);
                scrollTimeout = null;
            }
            scrollTimeout = setTimeout(fixed_layout, 5);
        }

        EVENT_init();
        Run_carousel();
        $document.scroll(EVENT_scroll).scroll();
        } 
    })(jQuery)
</script></section> <!-- /.block -->
  </div>
</footer>
  <script src="https://www.ithome.com.tw/sites/default/files/js/js_VU7P4CTgUZdF2SyFko5LLAg9ZK0OSVjXVaAFnTLgVt0.js"></script>
</body>
</html>
