圖片來源: 

Google

Google在自家部落格宣布,Google雲端運算平臺上的HTTPS和SSL代理負載平衡服務現在適用SSL政策,用戶能設定可接受客戶端的TLS最低版本,以及選擇負載平衡服務適用的密碼套件(Cipher Suite)。

當使用負載平衡服務當作HTTPS或是SSL的前端時,用戶需要能夠控制與客戶端連線的安全機制,在某些安全以及法遵需求下,用戶甚至需要控制所使用TLS協定的版本以及密碼套件,或者在較舊版本的應用程式,需要支援較舊版本的TLS功能。

Google軟體工程師David Gingold表示,TLS協定是20年前制訂的,時至今日,功能以及標準不停地變動,從剛問世的SSL,經過了幾個版本的演變,到現在普遍使用的TLS,每個版本都新增了一些新的加密技術,或是改進效能表現,但使用TLS時,伺服器與客戶端需要精確的協商使用的版本以及密碼套件。

David Gingold說,使用SSL政策功能,可以容易的解決這些問題,透過設定就能控制負載平衡服務可接受的TLS功能。


Advertisement

更多 iThome相關內容