Unity發布了Linux平臺上的Unity編輯器,為Linux平臺開發者提供即時的遊戲開發體驗,不過這個編輯器目前僅適用於Ubuntu和CentOS兩個Linux發布版,而且也仍在預覽階段。官方提醒,要以Linux平臺的Unity編輯器開啟專案前,要先確保其他第三方工具也有支援。

Unity一直為Linux開發者提供一個非官方的實驗性編輯器,但官方提到,越來越多開發者使用這個版本,而且在電影、車載、運輸以及製造等行業的用戶需求不停上升,因此Unity官方決定扶正Linux版本Unity編輯器,並預計在Unity 2019.3的時候完全支援。

從Unity 2019.1開始,所有使用者都可以使用Linux版本Unity編輯器,作業系統支援Ubuntu 16.04、18.04以及CentOS 7版本,硬體要求x86-64架構,而桌面環境要求在X11視窗系統上執行的Gnome,繪圖卡同時支援Nvidia以及AMD Mesa,並優先支援官方提供的驅動程式。官方提到,由於讓Unity編輯器穩定執行是他們的優先任務,因此先針對上述的配置進行調校。


Advertisement

更多 iThome相關內容